欢迎来到淘文阁 - 分享文档赚钱的网站! | 帮助中心 好文档才是您的得力助手!
淘文阁 - 分享文档赚钱的网站
全部分类
  • 研究报告>
  • 管理文献>
  • 标准材料>
  • 技术资料>
  • 教育专区>
  • 应用文书>
  • 生活休闲>
  • 考试试题>
  • pptx模板>
  • 工商注册>
  • 期刊短文>
  • 图片设计>
  • ImageVerifierCode 换一换

    JAVA编程风格.doc

    • 资源ID:70332363       资源大小:34KB        全文页数:5页
    • 资源格式: DOC        下载积分:15金币
    快捷下载 游客一键下载
    会员登录下载
    微信登录下载
    三方登录下载: 微信开放平台登录   QQ登录  
    二维码
    微信扫一扫登录
    下载资源需要15金币
    邮箱/手机:
    温馨提示:
    快捷下载时,用户名和密码都是您填写的邮箱或者手机号,方便查询和重复下载(系统自动生成)。
    如填写123,账号就是123,密码也是123。
    支付方式: 支付宝    微信支付   
    验证码:   换一换

     
    账号:
    密码:
    验证码:   换一换
      忘记密码?
        
    友情提示
    2、PDF文件下载后,可能会被浏览器默认打开,此种情况可以点击浏览器菜单,保存网页到桌面,就可以正常下载了。
    3、本站不支持迅雷下载,请使用电脑自带的IE浏览器,或者360浏览器、谷歌浏览器下载即可。
    4、本站资源下载后的文档和图纸-无水印,预览文档经过压缩,下载后原文更清晰。
    5、试题试卷类文档,如果标题没有明确说明有答案则都视为没有答案,请知晓。

    JAVA编程风格.doc

    The Definitive CS106 Style GuideTable of Contents:Why Should I Care about Style?Good NamingCommentingDecompositionWhitespaceInstance vs. Local VariablesElegant Code StructureAlways Use Constants:General and Reusable Methods:There Are Many Ways To Solve the Same Problem:Short Methods:Why Should I Care about Style?It's common when you're writing code to think it's self- explanatory. However, for anyone (yourself included) who's seeing code either for the first time or for the first time in a few days, the way the code works isn't always immediately obvious. The reason good style is important is because well-structured, easy-to-read code is easier to modify, easier to debug and easier to work with. This is something that will save you hours of work.When in doubt as to whether you should do something for style reasons ("should I comment this line?"), just remember the spirit of code style: the object is to make your code as readable as possible. Here are some tips to make your programming style better and the life of anyone reading it much easier!Good NamingUse meaningful names, but don't go overboard. Suppose you have a variable in your program that holds the number of hours employees worked in a week:/*OK, but not very descriptive*/int hours = 40;/*much more descriptive, but cumbersome*/int hoursTheWorkersWorkedInOneWeek = 40;/*a good compromise*/int hoursPerWeek = 40;Common abbreviations are often acceptable in variable names, like hrsPerWeek. But don't get carried away; hrsPWk simply is not a good name.Part of good style is good naming. You want your method name to succinctly describe what it does. Never call a method doStuff, give it a good specific name like isOdd. Be consistent in how you name your methods. In our solutions, we will use lower camel case naming conventions.CommentingMake sure to comment every method you write, and describe what the method does, and what the assumptions are before and after it is called. Write your comments so that your program could easily be understood by another person. In general, remember to have one comment describing the entire program, thena few lines above the function header for each function describing the purpose of the function,plus any pre-conditions or assumptions of the function and maybe some lines elaborating uponthe parameters if necessary. It's also good to comment when you're writing code that deals withan edge case or when your code refers to other sections of your code so the reader doesn't have to scroll everywhere. Commenting is best done while coding, not after youve finished.But there's such a thing as too much of a good thing. To illustrate, here's an example of over- commented code:for (int /*i is of type int*/ i = 0 /*initializing the variable i*/; i < 10;i+ /*incrementing i by one*/) /the start of the body of the forloopprintln/*prints the following string*/(/*here comes the string!*/"Hello, World!"/*that was the string!*/); /the end of the body of forloopDecompositionThe general idea is the following: if a block of code performs a specific solitary function. These numbers are not meant to be taken verbatim; always use your judgement.Someone whos never seen any code before should be able to figure out your program's algorithm merely from looking at your run() function. Good function naming also plays a role, here, too, obviously, but the main point is about decomposition.Good:bool IsCoordValid(int row, int col, int maxRows, int maxCols) return (row >= 0) && (row < maxRows) && (col >= 0) && (col < maxCols);Bad:int Zero() return 0;WhitespaceInside a function, statements which form logical actions should be grouped together with adequate space to set it apart from the rest of the code. Variable declarations should also be set apart.There's another kind of whitespace that's important, horizontal whitespace:/* many terms with no spaces: never do this */int i=2*i+12/i;/* spaces around every operator: good */int i = 2 * i + 12 / i;/* using parentheses for readability and grouping: the best */int i = (2 * i) + (12 / i);Instance vs. Local VariablesIt can be tempting to make everything an instance variable, once you've used them a few times. You should use as few instance variables as possible. Constants, on the other hand, are usually declared outside of functions (and hence have the same scope as instance variables).Always Use Constants:Our code should never contain “magic numbers,” meaning numbers we use in our code that dont have a clear meaning. For example don't just have “7,” say DAYS_IN_WEEK. Instead of “10,” we write EYE_RADIUS. Well-named constants make it clear what the purpose of the variable is, and also reduce errors. If someone wants to change the EYE_RADIUS, they can modify its value everywhere in the program by only changing it once. If we just wrote “10,” they would have to go searching through the code to find all the places we use this value. The only numbers we don't need to turn into constants are the numbers 0,1 and sometimes 2.General and Reusable Methods:It is important to write methods that are general and reusable. If you find yourself copying and pasting code, this is probably a sign that you should have a more general method to accomplish this task. However, figuring out how to write general and reusable methods is an art, and is quite challenging. Look for similarities in your code, or ask yourself how you can use parameters.There Are Many Ways To Solve the Same Problem:Every problem can be solved in a number of ways. When you write your own programs try and consider the many ways to solve the problem, and the trade-offs and benefits of each solution.Short MethodsWe could have written our whole program in the run method, but it is not good style and is difficult to follow. Try and break it down into methods that are small, understandable pieces of code, and accomplish one main task.Contributors:bgwinesjkeeshinFurther Reference:http:/www.cs.arizona.edu/mccann/style_c.htmlAre you an SL who would like to contribute or improve this document? Email jkeeshinstanford.edu

    注意事项

    本文(JAVA编程风格.doc)为本站会员(asd****56)主动上传,淘文阁 - 分享文档赚钱的网站仅提供信息存储空间,仅对用户上传内容的表现方式做保护处理,对上载内容本身不做任何修改或编辑。 若此文所含内容侵犯了您的版权或隐私,请立即通知淘文阁 - 分享文档赚钱的网站(点击联系客服),我们立即给予删除!

    温馨提示:如果因为网速或其他原因下载失败请重新下载,重复下载不扣分。




    关于淘文阁 - 版权申诉 - 用户使用规则 - 积分规则 - 联系我们

    本站为文档C TO C交易模式,本站只提供存储空间、用户上传的文档直接被用户下载,本站只是中间服务平台,本站所有文档下载所得的收益归上传人(含作者)所有。本站仅对用户上传内容的表现方式做保护处理,对上载内容本身不做任何修改或编辑。若文档所含内容侵犯了您的版权或隐私,请立即通知淘文阁网,我们立即给予删除!客服QQ:136780468 微信:18945177775 电话:18904686070

    工信部备案号:黑ICP备15003705号 © 2020-2023 www.taowenge.com 淘文阁 

    收起
    展开